Skip to content

Installing Required Tools and Libraries

To create the binary RPM the required packages listed in the table below must be installed. The packages differ based on the Linux distributions running on the host PC/workstation. Install the packages listed in the column that match the Linux distribution running on the workstation.

Packages Required for Different Linux Distributions

Description CentOS & Red Hat SLED
Compiler gcc gcc
Kernel header files required to build kernel driver Kernel-devel Kernel-default-devel
Tools used to build RPM files rpm-build Not required

To install these packages on CentOS or Red Hat:

  1. Open Terminal and type:
   sudo yum install gcc
   sudo yum install kernel-devel
   sudo yum install rpm-build

To install these packages on SLED:

  1. Open Terminal and type:
   sudo zypper install gcc
   sudo zypper install kernel-default-devel

Notes

  • If the kernel-devel or kernel-default-devel package must be installed, ensure you install the version compatible with the kernel installed on the workstation. If you install the wrong version, the driver fails to build and the error message install: cannot start `pcoip_host.ko': No such file or directory appears while installing the RPM file created by the createRPM script. See Tested Linux Distributions for which Linux distributions (kernel-devels) are supported.

  • Non-root users can install the fakeroot package to run the createRPM script.